Results 1 to 5 of 5

Thread: Clock Issues

  1. #1
    Sport Button On - DSC Off jpklecker's Avatar
    Join Date
    Dec 2006
    Posts
    110

    Question Clock Issues

    The clock on my 2002 Z8 seems to continually loose time. I've noticed that if the car sits for about a week, the clock will loose as much as 2-3 minutes during that time. If the car is used daily, I still have to reset it every 4-5 days. Has anyone else encountered this problem? Any recommendations to correct this?

  2. #2
    Z8 Addict Z8doc's Avatar
    Join Date
    Jan 2004
    Posts
    889

    Have you had your battery checked?

    Even though idle and not running, has many electrical systems still using power. The alarm, if on when in the garage is a big one but also, the phone, clock, and other power systems that need to be on in the OBDII system. If your battery is now 5 years old, I would suggest replacing it. If you use the Optima battery posted here on another thread, you will save alot of weight in the process.

    I had similar issues until I tested my battery and found it was dead prematurely and BMW replaced mine with warranty.
    Best Regards,

    Jeff
    61995 Silver /// Rot - Original Owner
    Z8 Club of Germany e.V. #102

  3. #3
    Sport Button On - DSC Off jpklecker's Avatar
    Join Date
    Dec 2006
    Posts
    110
    Thanks for the info, however the clock on my car has always lost time, even when the car was new. The current battery in the car was replaced, under warranty at around 3 years. The current battery is not quite 2 years old.

    I don't leave the phone in the car and when parked in my garrage at home I don't activate the alarm system. The only time the alarm is on is while the car is parked somewhere other than at home. My usual drive to work and most stores is about 25 - 30 minutes so this should help hold the charge if the car is used regularly.

    I will check the barttery status just in case you are right about this -- don't want to get stuck somewhere!

  4. #4
    Z8 Addict Z8doc's Avatar
    Join Date
    Jan 2004
    Posts
    889
    I see you live in the southwestern US and in my experience, the very hot humid and very hot dry climates are very hard on car batteries and when living in those climates, I always had to replace the battery much more frequently than what the "warranty" would suggest (i.e, 3 year warranty on a Sears gold, the battery would be toast only after 2 years). If not, maybe just get a new clock, it might be defective, even though it was made in Germany. ;-)
    Best Regards,

    Jeff
    61995 Silver /// Rot - Original Owner
    Z8 Club of Germany e.V. #102

  5. #5
    Sport Button On
    Join Date
    Nov 2002
    Posts
    34

    Cool

    Quote Originally Posted by jpklecker View Post
    The clock on my 2002 Z8 seems to continually loose time. I've noticed that if the car sits for about a week, the clock will loose as much as 2-3 minutes during that time. If the car is used daily, I still have to reset it every 4-5 days. Has anyone else encountered this problem? Any recommendations to correct this?
    I have had the same problem since new 2001. Usually slow 2 o 3 minutes per month