Results 1 to 6 of 6

Thread: Soft top header rail overshoots screen anchor points

  1. #1
    Sport Button On lamakdaddy's Avatar
    Join Date
    Feb 2014
    Posts
    34

    Soft top header rail overshoots screen anchor points

    When I close the top, the anchor points on the soft top are too far ahead to latch, I have to physically push the anchor points back for it to latch...anyone know of any adjustment points..

  2. #2
    I have never heard of that before, it sounds like the top has been taken off for repair and reassembled incorrectly.
    Andrew Macpherson

    Expert Z8 Inspections, with full support for both Z8 sale and purchases.

  3. #3
    Team Z8 tomfakes's Avatar
    Join Date
    Sep 2005
    Posts
    358
    My soft top sometimes needs to be pulled back a very small amount to get the latches into the slots. It's never more than a few mm though, and just as often doesn't need the pull back. My top is original, and has done this since new.

  4. #4
    Z8 Novice
    Join Date
    Dec 2005
    Posts
    15
    My top has always done the same as Tom's. A minor irritant so I have just lived with it.

  5. #5
    My top used to do this once in awhile. Now it's just about every time. I can usually back up the top a few inches and lower again. It lines up on the second go.
    Eric Wentzel

    2001 Z8 silver / black
    2008 650i cp silver / black


  6. #6
    Sport Button On lamakdaddy's Avatar
    Join Date
    Feb 2014
    Posts
    34
    Quote Originally Posted by ericw View Post
    My top used to do this once in awhile. Now it's just about every time. I can usually back up the top a few inches and lower again. It lines up on the second go.
    My BMW dealer managed to fix it. It took 2 hours and they had to remove the header rail from the softtop as far as I understand..

Similar Threads

  1. Don't ignore your soft top
    By pandaman in forum Tips, Tricks & Useful Bits
    Replies: 17
    Last Post: August 31st 2013, 21:49
  2. Soft top won't go down
    By 2000Z8 in forum Z8 Chat Room
    Replies: 17
    Last Post: June 1st 2012, 16:21
  3. Z8 with flip out 7" screen installed
    By ZMates in forum Stereo, Phone, Nav & Radar Detectors
    Replies: 13
    Last Post: February 28th 2011, 15:53
  4. soft top not working
    By ratacruel in forum Problems, Solutions and Long Term Maintenance
    Replies: 5
    Last Post: April 13th 2010, 19:38
  5. soft top help please
    By pandaman in forum Z8 Chat Room
    Replies: 2
    Last Post: June 14th 2008, 01:32