Results 1 to 8 of 8

Thread: Can you guys help me with my brothers car?

  1. #1
    Sport Button On - DSC Off
    Join Date
    Oct 2011
    Posts
    141

    Can you guys help me with my brothers car?

    He has JUST called me as he is in the Z, just filled it up with Shell gas, check engine light says service soon, 23K miles, think it is a 2001, it is like running on 6 cylinders as he put it, limping along.., then light went off and now is running fine. Is this a VANOS sign or something else that comes to mind besides BAD GAS? thanks GUYS! Max

  2. #2
    It is the 'limp home' mode, but why it came on is a mystery, I don't think gas would do it, but not replacing the gas cap would. I've only ever had it come on during very hot weather, running hard with AC on. it is more likely to be a bad sensor or MAF at a guess. The VANOS will fail loudly, so if there is no unusual top end sounds I think it's a sensor.
    Andrew Macpherson

    Expert Z8 Inspections, with full support for both Z8 sale and purchases.

  3. #3
    Z8Mania
    Guest
    Yeah, he should bring it to the dealer right away for them to plug it in to the computer.

  4. #4
    Sport Button On - DSC Off
    Join Date
    Oct 2011
    Posts
    141

    thnx! Gas cap makes sense!

    He did fill up; said like 10-12 minutes before the event, thnx! Max

  5. #5
    Z8Mania
    Guest
    Most modern cars will throw a cheek engine light if there is a break in the seal between the gas cap and the fuel tank. If its really driving smoothly with no weird sounds or signs then when the car is not running Id remove the gas cap, then re seal it make sure its nice and tight. And then go for a gentle drive of about 30 miles and see if the light comes back. Id try to keep the revs down just in case. thats just me. The most conservative thing is to bring the car to the dealer.

  6. #6
    DSC Off
    Join Date
    Mar 2006
    Posts
    53
    If he filled the car up while it was running, that message comes on.

    After 3 fillups with z not running......oila, the light goes off.

    I had the same issue.

    Jim
    Z84.6Jim

  7. #7
    Administrator thegunguy's Avatar
    Join Date
    Sep 2005
    Posts
    2,701
    CEL can be many things. Without the codes, there's not much any of us can do other than speculate. If it doesnt reset on restart, he'll need to take it in for service. I'd start there.
    thegunguy

  8. #8
    Z8Mania
    Guest
    Right. You can take your chances and thats just a guess, or you can go to the dealer and know. Yes its a pain to attain the knowledge.