Results 1 to 6 of 6

Thread: soft top not working

  1. #1
    Z8 Novice
    Join Date
    Dec 2009
    Posts
    11

    soft top not working

    any one knows why my soft top light on the dash is flasing and the soft top is not operational ??? I try every thing.

  2. #2
    Yes, had that happen earlier this year, it is an easy fix, the mechanism just needs to be initialized at the dealership. It isn't a big deal, just an electrical thing.
    Andrew Macpherson

    Expert Z8 Inspections, with full support for both Z8 sale and purchases.

  3. #3
    Z8 Novice
    Join Date
    Dec 2009
    Posts
    11
    Quote Originally Posted by macfly View Post
    Yes, had that happen earlier this year, it is an easy fix, the mechanism just needs to be initialized at the dealership. It isn't a big deal, just an electrical thing.
    hi macfly. you have helped me in the past , is that what I tell the dealer to initialized the system??? is there any way of doing it my self??

  4. #4
    Silver/Black
    Join Date
    Apr 2010
    Posts
    5
    Hi! had the same problem two weeks ago after winter storage. try to unplug and plug the battery several times. It helped me. good luck.

  5. #5
    Yes, I keep my soft top in the up position, but not latched tight. I found by using the handle to do the manual open, then taking the car for a short drive to the gas station, it just closed up and worked fine again after that. I didn't even have to initalize it at the dealer. Don't quite know what the issue is, but seems sort of like the heater/ac switch thing, it sort of sorts itself out.
    Andrew Macpherson

    Expert Z8 Inspections, with full support for both Z8 sale and purchases.

  6. #6
    Sport Button On - DSC Off
    Join Date
    Sep 2006
    Posts
    153
    A couple instances last year, I tried to put my top up and everything seemed fine but the top would not latch. It eventually latched but a bit disconcerting.